Программирование проблем atmega649v


albaben

albaben

3
Здравствуйте,
У меня очень странная проблема программирования atmega649v от BEKO. Всякий раз, когда я программирую atmega649v с файлом, который я сохранил на своем компьютере, экран не продолжается, но у него есть подсветка, но нет цифр и т. Д., И числа поступают на миллисекунду и уходят, каждую минуту или так. Однако, если я прочитал вспышку eeprom из другой atmega, которая работает правильно и немедленно запрограммирует другую atmega с этим файлом, еще одна atmega, она работает правильно. Но если я сохраню файл на своем компьютере и запрограммирую его позже, он придет с проблемой экрана, которую я объяснил. Я использую BeeProg2C для программирования с интернет-провайдером. Почему это происходит?
Спасибо.
23758279_10210622209130972_1188743970_n.jpg

Решение

выбрал другой способ сохранить файл на моем компьютере. сохранить как файл проекта. так преуспел.


Tor
Tor 20 ноября 2017
1
Смотри в программаторе настройки (columns и sections) должно (16 и 8).у меня так.
Для комментария нужно войти или зарегистрироваться
albaben
albaben 20 ноября 2017
Привет, извините, но я не могу найти те варианты, которые вы мне дали. Не могли бы вы объяснить или отправить мне скриншот? Спасибо.
Tor
Tor 20 ноября 2017
У Вас программатор другой и настройки могут быть другими, но указанная Вами проблема. была и у меня, нужно смотреть настройки в програматоре и все получится.Извиняюсь за качество фото.
20112017466.jpg
Tor
Tor 20 ноября 2017
skypro_1.3.0.1 вот моя программа она в свободном доступе, скачай и сравни со своей прогой.
albaben
albaben 26 ноября 2017
пожалуйста, поместите куда-нибудь более четкие снимки, которые я сравниваю с осторожностью.

Gaetanus
Gaetanus 20 ноября 2017
1
Привет, вы пытались сменить папку спасения?
Вы пробовали его с другого компьютера?
Есть ли какие-то вариации?
Для комментария нужно войти или зарегистрироваться
albaben
albaben 20 ноября 2017
Привет, да, я пробовал другие папки, но я действительно сомневаюсь, что проблема связана с папкой или компьютером или даже с программой, потому что я пробовал много других MCU (например, atmega 644 для Candy), и они отлично работали, это происходит только с BEKO , программирование работает на месте, но не после сохранения файла. Он работает нормально, но когда я подключаю его к BEKO, он не работает.
Tor
Tor 20 ноября 2017
Твоя проблема в настройках программы 100%, я на этом MK.пол дня потерял пока не настроил программу, заливаю прошивку. процесс программирования проходит нормально без ошибок, а ставлю на СМА экран светится чистый,такая проблема и у тебя.

matrix7867
matrix7867 20 ноября 2017
1
Не правильно сохраняете прошивку. Смотрите в сторону USBASP для Atmel.
Для комментария нужно войти или зарегистрироваться

Nic
Nic 21 ноября 2017
1
albaben, при стирании МК, установки Lock битов тоже стираются. После прошивки МК не забывайте о необходимости их программирования.
Для комментария нужно войти или зарегистрироваться
Nic
Nic 21 ноября 2017
Проверьте.
2017-11-21_011704.jpg
albaben
albaben 26 ноября 2017
Я проверил программиста beeprog2c, и записи записаны на картинке. Удивительно, что с помощью ATMEGA, который имеет CANDY, у меня нет проблем во время программирования. У меня только проблемы с ATMEGA, которые имеют модули BEKO. По крайней мере, это я понимаю.
еще раз:
- когда я прочитал нормальный ATMEGA и отключил соединение ISP от программиста, а затем поместил модуль, который я установил на новый ATMEGA, и я хочу программу, все работает.
в то время как когда я сохраняю файл, который я прочитал, то через несколько дней мне нужно запланировать другое, это не сработает.
эта проблема возникает только у программиста beeprog2c. в то время как с TL866A (minipro) у меня нет этой проблемы.

Для комментария нужно войти или зарегистрироваться